GNS3 – OSPF Lab – 4ème partie

Voici le quatrième volet de la configuration de notre lab OSPF. Dans cet article, nous verrons comment configurer OSPF pour fonctionner sur un réseau Frame-Relay dans une topologie Hub&Spoke…

Rappel de la topologie

La problématique

OSPF est un protocole performant mais rigoureux. Simple à mettre en place sur un LAN ou sur des liaisons point-à-point, il se révèle bien plus capricieux sur un réseau Frame-Relay et tout particulièrement dans une topologie Hub&Spoke.

Par défaut lorsqu’on active OSPF sur une interface en Frame-Relay, OSPF s’adapte en définissant l’interface comme un « network Non-Broadcast », ce qui est logique … puisque Frame-Relay est bien un type de réseau NBMA (Non Broadcast Multi Access). Là où les choses se compliquent, c’est dans le comportement induit par ce type de réseau, à savoir :

Sur un réseau Non-Broadcast:

  • OSPF n’établit pas d’adjacence de manière dynamique
  • OSPF tente d’élire un DR (Designated Router) et un BDR (Backup Designated Router).

L’élection d’un DR et d’un BDR fonctionne parfaitement si on se trouve sur une topologie Full-Mesh qui se comporte approximativement comme un LAN ethernet… hors ici nous avons une topologie Hub&Spoke, donc pas de PVC entre tous les routeurs, ce qui implique que nous allons devoir forcer ABR4 (celui qui a une liaison vers les autres routeurs) à être le DR et empêcher les deux autres de devenir BDR.

Pour rappel, le DR est le routeur qui sert de centralisation pour les updates OSPF sur un réseau partagé. Chaque routeur envoi ses updates au DR et celui-ci les fait suivre ensuite à tous les routeurs du réseau partagé.

Première étape

Commençons par configurer le router Hub « ABR4″…

Première chose, la configuration de la bande passante de l’interface Serial 0/2. Celle-ci utilise deux PVCs chacun disposant d’un CIR de 128kbit/s, on lui attribuera donc une bande passante de 128kbits de sorte que le COST (qui sera le même pour les deux soit calculé en fonction de cette valeur).

ABR4(config)#interface s0/2
ABR4(config-if)#bandwidth 128
ABR4(config-if)#exit
ABR4(config)#

Ensuite, nous devons activer OSPF sur l’interface Serial0/2.

ABR4(config)#router ospf 1
ABR4(config-router)#network 172.16.40.0 0.0.0.255 area 40
ABR4(config-router)#

Puisque les adjacences ne se formeront pas dynamiquement, il faut configurer statiquement les voisins (R2 et R3).

ABR4(config-router)#neighbor 172.16.40.2
ABR4(config-router)#neighbor 172.16.40.3
ABR4(config-router)#exit

Afin de s’assurer que ABR4 soit le DR du réseau partagé, mieux vaut augmenter sa priorité (1 par défaut).

ABR4(config)#int s0/2
ABR4(config-if)#ip ospf priority 127
ABR4(config-if)#exit

Voilà qui devrait être suffisant pour ABR4, passons à R2 et R3.

Deuxième étape

Passons à R2. Au même titre que pour ABR4, nous allons devoir configurer statiquement le voisin (ABR4). Par contre, afin que la topologie fonctionne bien, nous devons faire en sorte qu’il ne tente pas de devenir DR ou BDR. Ce qui revient à configurer sa priorité à 0.

R2(config)#interface serial 0/0
R2(config-if)#bandwidth 128
R2(config-if)#ip os
R2(config-if)#ip ospf pr
R2(config-if)#ip ospf prio
R2(config-if)#ip ospf priority 0
R2(config-if)#exit
R2(config)#router ospf 1
R2(config-router)#router-id 8.8.8.8
R2(config-router)#network 172.16.40.0 0.0.0.255 area 40
R2(config-router)#network 192.168.24.1 0.0.0.255 area 40
R2(config-router)#neig
R2(config-router)#neighbor 172.16.40.1
R2(config-router)#exit
R2(config)#exit

Troisième étape

Il ne reste maintenant plus que R3 à configurer en suivant exactement le même principe que R2.

R3(config)#interface s0/0
R3(config-if)#bandwidth 128
R3(config-if)#ip ospf priority 0
R3(config-if)#exit
R3(config)#router ospf 1
R3(config-router)#router-id 9.9.9.9
R3(config-router)#network 172.16.40.0 0.0.0.255 area 40
R3(config-router)#network 192.168.34.0 0.0.0.255 area 40
R3(config-router)#neighbor 172.16.40.1
R3(config-router)#exit
R3(config)#exit

Quatrième étape

A priori tout semble être en ordre, R3 semble avoir une table de routage bien complète.

R3#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
O IA 192.168.30.0/24 [110/802] via 172.16.40.1, 00:01:09, Serial0/0
O    192.168.24.0/24 [110/791] via 172.16.40.2, 00:01:09, Serial0/0
     192.168.10.0/30 is subnetted, 2 subnets
O IA    192.168.10.0 [110/1563] via 172.16.40.1, 00:01:09, Serial0/0
O IA    192.168.10.4 [110/2344] via 172.16.40.1, 00:01:09, Serial0/0
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.40.0 is directly connected, Serial0/0
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
O IA    10.0.1.8/30 [110/1562] via 172.16.40.1, 00:01:09, Serial0/0
O IA    10.0.1.12/30 [110/1562] via 172.16.40.1, 00:01:09, Serial0/0
O IA    10.0.0.0/24 [110/782] via 172.16.40.1, 00:01:09, Serial0/0
O IA    10.0.1.0/30 [110/1563] via 172.16.40.1, 00:01:09, Serial0/0
O IA    10.0.1.4/30 [110/1563] via 172.16.40.1, 00:01:09, Serial0/0
O IA 192.168.23.0/24 [110/792] via 172.16.40.1, 00:01:10, Serial0/0
C    192.168.34.0/24 is directly connected, FastEthernet0/0
O E1 192.168.100.0/24 [110/2345] via 172.16.40.1, 00:01:10, Serial0/0
R3#

Toutefois, en regardant la table de routage de près, un problème apparaît. Le réseau 192.168.24.0/24 (La loopback de R2) est accessible via 172.16.40.2, adresse du même réseau que R3 … sauf que … il n’y a pas de PVC entre R2 et R3 et donc pas de connectivité entre ces deux routeurs !

R3#ping 192.168.24.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.24.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R3#

Etant donné que nous sommes dans une topologie Hub&Spoke il n’est pas question de créer un nouveau PVC pour lier ces deux routeurs. Dès lors il va falloir demander à ABR4 de relayer les trames frame-relay entre R2 et R3 … Cela se configure simplement par un nouveau mapping frame-relay.

De R2 pour joindre R3, on utilisera le PVC qui mène à R1, et de R3 pour joindre R2 on utilisera également le PVC qui mène à R1.

Sur R2…

R2(config)#interface s0/0
R2(config-if)#frame-relay map ip 172.16.40.3 24 broadcast
R2(config-if)#exit

Sur R3…

R3(config)#interface s0/0
R3(config-if)#frame-relay map ip 172.16.40.2 34 broadcast
R3(config-if)#exit

Vérifions…

R3#ping 192.168.24.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.24.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/45/144 ms
R3#

Cette fois, c’est bon !

Afin d’être sur du bon comportement d’OSPF, vérifions l’état de ABR4, celui-ci devrait être le DR du réseau frame-relay, et R2 et R3 n’étant ni DR, ni BDR devraient être vus comme DROTHER.

Sur ABR4…

ABR4#sh ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:00:32    10.0.1.14       Serial0/1
2.2.2.2           0   FULL/  -        00:00:36    10.0.1.10       Serial0/0
1.1.1.1           1   FULL/BDR        00:00:34    10.0.0.1        FastEthernet0/0
2.2.2.2           1   FULL/DR         00:00:38    10.0.0.3        FastEthernet0/0
3.3.3.3           1   2WAY/DROTHER    00:00:36    10.0.0.4        FastEthernet0/0
8.8.8.8           0   FULL/DROTHER    00:01:32    172.16.40.2     Serial0/2
9.9.9.9           0   FULL/DROTHER    00:01:32    172.16.40.3     Serial0/2
ABR4#

Voilà qui conclut cet article. A présent la topologie est fonctionnelle. Il ne reste plus qu’à améliorer le comportement par défaut, mais ce sera pour le prochain article.

VN:F [1.9.22_1171]
Rating: 9.5/10 (8 votes cast)
GNS3 - OSPF Lab - 4ème partie, 9.5 out of 10 based on 8 ratings
Posted in CCNP R&S, CCNP Routing, Certifications, Cisco, GNS3, La pratique, Routing
Tags: , , , , , , , , , , , ,
4 commentaires sur “GNS3 – OSPF Lab – 4ème partie
  1. shinichi dit :

    Très bon article. Le labo n’était pas compliqué: par contre il est complexe. Explications claires et les étapes bien développés.
    On attend la suite et d’autres labo. Et merci encore.

  2. Virtualyzer dit :

    labo très enrichissant manque juste une peu de difficultés pour pimenter le tout sinon excellent !!

  3. Milou dit :

    Bonjour,

    Je vous remercie infiniment pour ce LAB, il est très riche.

    Pour la 4eme partie, je n’ai pas pu declarer le neighbor 172.16.40.1 dans R2 et R3.

    J’obtiens ce message d’erreur:

    R2(config)#router ospf 1
    R2(config-router)#neighbor 172.16.40.1
    R2(config-router)#
    *Mar 1 01:34:47.207: %OSPF-4-CFG_NBR_INVAL_NET_TYPE: Can not use configured neighbor: neighbor command is allowed only on NBMA and point-to-multipoint networks

    Du coup j’aimerai savoir si y’a pas de configuration a faire dans le router FR, par exemple l’encapsulation des interfaces, la déclaration des DLCI… ?

    Merci d’avance.

Laisser un commentaire

Visit Us On FacebookVisit Us On GooglePlusVisit Us On TwitterVisit Us On LinkedinVisit Us On YoutubeCheck Our Feed

Archives

Connexion à WordPress protégée par Clef
%d blogueurs aiment cette page :