Configuration d’un routeur en Frame-Relay Switching

Voici comment, en quelques étapes, configurer un routeur pour qu’il agisse en switch Frame-Relay.

Pré-requis minimums:

  • 1 routeur supportant le frame-relay Switching, muni d’au moins 2 interfaces séries
  • 2 routeurs disposant chacun d’une interface série, et d’une interface ethernet.
  • 2 switch ethernet

Schéma utilisé pour l’exercice:

Frame-Relay

RT1

  • Serial 0/0: 10.0.0.1 /24, DLCI 102
  • Ethernet 0/0: 10.0.1.1 /24

RT2

  • Serial 0/0: 10.0.0.2 /24, DLCI 201
  • Ethernet 0/0: 10.0.2.1/24

RT-FR

  • Serial 1/0: no ip
  • Serial 1/1: no ip

SW1

  • VLAN1: 10.0.1.254 /24

SW2

  • VLAN1: 10.0.2.254 /24

Configuration de RT1 et RT2

RT1 et RT2 devront avoir chacun leur interface série avec une encapsulation Frame-Relay et avoir un DLCI défini dessus. Pour nommer facilement les DLCI, j’utilise la notation X0Y ou X est le routeur source, Y le routeur destination. Donc le DLCI 102 est utilisé pour le traffic venant de RT1 à destination de RT2, et le DLCI 201 est utilisé pour ce uqi vient de RT2 à destination de RT1. On part ici d’une configuration vierge…

Configuration de RT1

Router> enable
Router# configure terminal
Router(config)# hostname RT1
RT1(config)# line console 0
RTI(config-line)# logging synchronous
RT1(config-line)# exec-timeout 0 0
RT1(config-line)# exit
RT1(config)# interface serial 0/0
RT1(config-if)# ip address 10.0.0.1 255.255.255.0
RT1(config-if)# encapsulation frame-relay
RT1(config-if)# frame-relay interface-dlci 102
RT1(config-dlci)# exit
RT1(config-if)# no shutdown
RT1(config-if)# exit
RT1(config) interface ethernet 0/0
RT1(config-if)# ip address 10.0.1.1 255.255.255.0
RT1(config-if)# no shutdown
RT1(config-if)# exit
RT1(config)# exit
RT1# exit

Configuration de RT2

Router> enable
Router# configure terminal
Router(config)# hostname RT2
RT2(config)# line console 0
RT2(config-line)# logging synchronous
RT2(config-line)# exec-timeout 0 0
RT2(config-line)# exit
RT2(config)# interface serial 0/0
RT2(config-if)# ip address 10.0.0.2 255.255.255.0
RT2(config-if)# encapsulation frame-relay
RT2(config-if)# frame-relay interface-dlci 201
RT2(config-dlci)# exit
RT2(config-if)# no shutdown
RT2(config-if)# exit
RT2(config) interface ethernet 0/0
RT2(config-if)# ip address 10.0.2.1 255.255.255.0
RT2(config-if)# no shutdown
RT2(config-if)# exit
RT2(config)# exit
RT2# exit

Configuration de RT-FR

RT-FR agira comme switch frame-relay, c’est-à-dire que son rôle sera de relayer ce qui vient de RT1 vers RT2 et inversément. Pour celà on va devoir lui indiquer son rôle de switch frame-relay, mais également définir les routes frame-relay. Pour celà en configuration d’interface on utilise la commande suivante:

RT-FR(config-if) frame-relay route DLCI_IN interface INTERFACE_OUT DLCI_OUT
  • DLCI_IN est le n° du DLCI par où les données entrent
  • INTERFACE_OUT est le nom de l’interface par où on envoi les données
  • DLCI_OUT est le numéro du DLCI utilisé pour envoyer les données sur l’interface de sortie

On passe à la configuration de RT-FR:

Router> enable
Router# configure terminal
Router(config)# hostname RT-FR
RT-FR(config)# line console 0
RT-FR(config-line)# logging synchronous
RT-FR(config-line)# exec-timeout 0 0
RT-FR(config-line)# exit
RT-FR(config)# frame-relay switching
RT-FR(config)# interface serial 1/0
RT-FR(config-if)# encapsulation frame-relay
RT-FR(config-if)# frame-relay route 102 interface serial 1/1 201
RT-FR(config-if)# no shutdown
RT-FR(config-if)# exit
RT-FR(config)# interface serial 1/1
RT-FR(config-if)# enclapsulation frame-relay
RT-FR(config-if)# frame-relay route 201 interface serial 1/0 102
RT-FR(config-if)# no shutdown
RT-FR(config-if)# exit
RT-FR(config)# exit
RT-FR# exit

A présent, RT1 et RT2 devraient être capables de communiquer.  Par exemple en faisant un ping sur RT1: ping 10.0.0.2 Il reste maintenant à configurer les switch, et à mettre en place le routage pour que les machines connectées à SW1 puissent communiquer avec celles de SW2.

Sur SW1

Switch> enable
Switch# configure terminal
Switch(config)# hostname SW1
SW1(config)# line console 0
SW1(config-line)# logging synchronous
SW1(config-line)# exec-timeout 0 0
SW1(config-line)# exit
SW1(config)# interface vlan 1
SW1(config-if)# ip address 10.0.1.254 255.255.255.0
SW1(config-if)# no shutdown
SW1(config-if)# exit
SW1(config)# exit
SW1# exit

Sur SW2

Switch> enable
Switch# configure terminal
Switch(config)# hostname SW2
SW2(config)# line console 0
SW2(config-line)# logging synchronous
SW2(config-line)# exec-timeout 0 0
SW2(config-line)# exit
SW2(config)# interface vlan 1
SW2(config-if)# ip address 10.0.2.254 255.255.255.0
SW2(config-if)# no shutdown
SW2(config-if)# exit
SW2(config)# exit
SW2# exit

Logiquement SW1 devrait pouvoir communiquer avec RT1 et SW2 avec RT2. Il ne reste maintenant plus qu’à mettre en place le routage. Pour celà on va activer RIP sur RT1 et RT2 pour le réseau 10.0.0.0.

Sur RT1

RT1> enable
RT1# configure terminal
RT1(config)# hostname RT2
RT1(config)# line console 0
RT1(config)# router rip
RT1(config-rip)# version 2
RT1(config-rip)# network 10.0.0.0
RT1(config-rip)# exit
RT1(config)# exit
RT1# exit

Sur RT2

RT1> enable
RT2# configure terminal
RT2(config)# hostname RT2
RT2(config)# line console 0
RT2(config)# router rip
RT2(config-rip)# version 2
RT2(config-rip)# network 10.0.0.0
RT2(config-rip)# exit
RT2(config)# exit
RT2# exit

A présent SW1 devrait pouvoir communiquer avec SW2.

VN:F [1.9.22_1171]
Rating: 9.3/10 (8 votes cast)
Configuration d'un routeur en Frame-Relay Switching, 9.3 out of 10 based on 8 ratings
Posted in Cisco, La pratique
Tags: , , , , ,
2 commentaires sur “Configuration d’un routeur en Frame-Relay Switching
  1. Haltar dit :

    Bonjour,

    J’écris ici pour informer qu’étant donné que l’ancien nom de domaine n’est plus valable, l’image sur cette page à besoin d’une petite à jour avec ce nouveau lien : « http://www.ciscomadesimple.be/wp-content/uploads/2009/09/framerelay.jpg »

    En tout cas, merci pour toutes ces infos très utiles.

    Haltar

  2. Merci pour l’info, c’est corrigé.

Laisser un commentaire

Visit Us On FacebookVisit Us On GooglePlusVisit Us On TwitterVisit Us On LinkedinVisit Us On YoutubeCheck Our Feed

Archives

Connexion à WordPress protégée par Clef
%d blogueurs aiment cette page :