Frame-Relay – Configuration d’un topologie de type Full-Mesh

Cet article présente une configuration fonctionnelle pour trois routeurs interconnectés via un réseau frame-relay dans une topologie de type full-mesh, c’est à dire où chaque routeur a une liaison directe vers chaque autre routeur.

La topologie

Chaque routeur est connecté au switch frame-relay via son interface Serial0/0. De plus,sur chacun d’eux une interface loopack est créée pour simuler la présence d’un LAN.

Le Switch Frame-Relayest configuré de la manière suivante:

  • Pour atteindre R1 on utilise le DLCI 100
  • Pour atteindre R2 on utilise le DLCI 200
  • Pour atteindre R3 on utilise le DLCI 300

Sur chaque routeur, inverse-arp est désactivé. Ce qui implique qu’il faut définir manuellement le mapping entre les adresses IP et les DLCI à utiliser.

RIP est utilisé pour propager les routes des LANs.

Configuration des routeurs

Routeur R1

R1 servira d’exemple pour la configuration, en partant du principe qu’aucune configuration n’a été faite en dehors du hostname.

Tout d’abord on s’occupe de configurer l’interface serial 0/0

R1> enable
R1# configure terminal
R1(config)# interface serial 0/0
R1(config-if)# encapsulation frame-relay
R1(config-if)# no frame-relay inverse-arp
R1(config-if)# ip address 172.16.0.1 255.255.255.0
R1(config-if)# no shutdown

A ce moment, l’interface devrait passer « up/up ». Il faut maintenant définir le mapping pour atteindre R2 et R3. Pour celà, il faut indique quel DLCI le routeur doit associer aux adresses IP de R2 et R3. De plus, vu qu’on va utiliser RIP (ce serait valable aussi pour lesautres protocoles de routages qui fonctionnent sur base des multicasts) il faut préciser l’option « broadcast » dans le mapping. (Frame-Relay est un réseau de type NBMA … Non-Broadcast Multiple Access … ce qui signifie que les broadcast et multicast ne sont pas supportés, il faut donc forcer le routeur à envoyer autant de « message » qu’il y a d’hôtes reliés par l’intermédiaire des PVCs).

R1(config-if)#  frame-relay map ip 172.16.0.2 200 broadcast
R1(config-if)#  frame-relay map ip 172.16.0.3 300 broadcast
R1(config-if)#  exit

Il reste maintenant à créer l’interface loopback et à la configurer.

R1(config)# interface loopback 0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)# exit

Inutile de faire « no shutdown » sur cette interface, une interface loopback est toujours up/up.

Dernière étape, la configuration de RIP, en version 2 (obligatoire puisqu’on utilise ici des adresses qui ne respectent pas toutes les classes A/B/C). On va également désactiver l’auto-summary, même si dans le cas présent ce n’est pas nécessaire (il n’y a pas de réseau majeur dis-contigu).

R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# no auto-summary
R1(config-router)# network 172.16.0.0
R1(config-router)# network 192.168.1.0
R1(config-router)# exit
R1(config)# exit
R1# copy running-config  startup-config

Voilà qui clôture la configuration de R1. Il ne reste plus qu’à faire de même pour R2 et R3.

Startup-config de R1, R2 et R3

Voici les startup-config de R1, R2 et R3. Seules les lignes utiles à cette configuration sont reprises (interfaces, config routeur, …).

Startup-config de R1

hostname R1
interface Loopback0
ip address 192.168.1.1 255.255.255.0
interface Serial0/0
ip address 172.16.0.1 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.0.3 300 broadcast
frame-relay map ip 172.16.0.2 200 broadcast
no frame-relay inverse-arp
router rip
version 2
passive-interface Loopback0
network 172.16.0.0
network 192.168.1.0
no auto-summary

Startup-config de R2

hostname R2
interface Loopback0
ip address 192.168.2.1 255.255.255.0
interface Serial0/0
ip address 172.16.0.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.0.1 100 broadcast
frame-relay map ip 172.16.0.3 300 broadcast
no frame-relay inverse-arp
router rip
version 2
passive-interface Loopback0
network 172.16.0.0
network 192.168.2.0
no auto-summary

Startup-config de R3

hostname R3
interface Loopback0
ip address 192.168.3.1 255.255.255.0
interface Serial0/0
ip address 172.16.0.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 172.16.0.1 100 broadcast
frame-relay map ip 172.16.0.2 200 broadcast
no frame-relay inverse-arp
router rip
version 2
passive-interface Loopback0
network 172.16.0.0
network 192.168.3.0
no auto-summary

Maintenant que les configurations sont en place, il ne reste plus qu’à vérifier que les routeurs ont les routes pour les différents réseaux des interfaces loopback.

Vérification sur R1

R1#show  ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
172.16.0.0/24 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, Serial0/0
C    192.168.1.0/24 is directly connected, Loopback0
R    192.168.2.0/24 [120/1] via 172.16.0.2, 00:00:09, Serial0/0
R    192.168.3.0/24 [120/1] via 172.16.0.3, 00:00:23, Serial0/0
R1#

R1 a donc bien appris les routes vers les réseaux des loopbacks de R2 et R3.

On peut également vérifier le mapping frame-relay:

R1#sh frame-relay map
Serial0/0 (up): ip 172.16.0.2 dlci 200(0xC8,0x3080), static,
broadcast,
CISCO, status defined, active
Serial0/0 (up): ip 172.16.0.3 dlci 300(0x12C,0x48C0), static,
broadcast,
CISCO, status defined, active
R1#

R1 a bien deux mappings définis. Les deux sont fonctionnels (active), ont été défini de manière statique via la commande frame-relay map ip et ont été configurés pour traiter les broacasts et multicasts.

Voilà qui conclut cet article.

VN:F [1.9.22_1171]
Rating: 9.3/10 (4 votes cast)
Frame-Relay - Configuration d'un topologie de type Full-Mesh, 9.3 out of 10 based on 4 ratings
Posted in CCNA - ICND2, Certifications, Cisco, La pratique
Tags: , , , , , , , , , ,
4 commentaires sur “Frame-Relay – Configuration d’un topologie de type Full-Mesh
  1. Philippe dit :

    Bonjour,

    Je fais un lab sur GNS3.
    J’aurais une question. Comment sont construits les PVC au niveau du switch ? Car ne faut-il pas faire des mappings source/destination ?

    • Au niveau du switch on parle de « routes » frame-relay. Le principe est de dire que les données arrivant par le DLCI X sur l’interface A doit être propagées vers l’interface B sur le DLCI Y. La manière de faire dépendra dans GNS3 de ce qu’on utilise pour le switch Frame-Relay (soir le switch frame-relay intégré, soit un routeur que l’on configure en frame-relay switching, comme décrit dans CET article.

  2. james stanley dit :

    salut
    voila mon probleme
    voila mon cas. il me faut interconnecter plusieurs sites. En theorie je sais comment configurer le partial mesh ainsi que le full mesh. Apres avoir fini de diviser une interface en plusieurs sous-interfaces, comment faire pour relier physiquement les autres routeurs a une interface divisee en plusieurs sous-interfaces?

  3. Physiquement les routeurs doivent être connectés à un Switch Frame-Relay ou un équipement qui joue ce rôle du moins. C’est au niveau de cet équipement que sont définis les DLCI et vers où ils mènent.
    Dans l’article ci-dessous j’explique comment configurer un routeur en switch frame-relay dans le cadre d’un labo de test ou d’apprentissage.
    http://www.ciscomadesimple.be/2009/09/06/cisco-configuration-dun-routeur-en-frame-relay-switching/

    Dans la réalité c’est le provider qui met le service à disposition bien entendu.

Laisser un commentaire

Visit Us On FacebookVisit Us On GooglePlusVisit Us On TwitterVisit Us On LinkedinVisit Us On YoutubeCheck Our Feed

Archives

Connexion à WordPress protégée par Clef
%d blogueurs aiment cette page :