Configuration de base de RIP

Quand on veut configurer le routage IP entre plusieurs routeurs, on peut bien sur définir les routes statiques, toutefois l’utilisation de protocoles de routage facilite grandement la tâche puisqu’ils permettent de propager les routes d’un routeur à un autre moyennant une configuration adéquate. Cert article reprend la configuration minimale pour faire fonctionner RIP.

Situation

Le schéma ci-dessous reprend la configuration du réseau pour lequel on activera le protocol de routage RIP:

[ 10.0.1.0/24 ]------( R1 )------+ 10.0.3.0/30
                                 |
                               ( R3 )------> [Internet]
                                 |
[ 10.0.2.0/24 ]------( R2 )------+ 10.0.3.4/30

Routeur R1

  • 1 Interface FastEthernet Fa0/1 (Lan): 10.0.1.1/24
  • 1 Interface Série s1/0: 10.0.3.2/30

Routeur R2

  • 1 Interface FastEthernet Fa0/1 (Lan): 10.0.2.1/24
  • 1 Interafce Série s1/0: 10.0.3.6/30

Routeur R3

  • 1 Interface série s1/0 vers R1: 10.0.3.1/30
  • 1 Interface Série s1/1 vers R2: 10.0.3.5/30
  • 1 Inetrface Série s1/2 vers le réseau extérieur

On souhaite que le routage complet du réseau 10.0.0.0 soit géré par RIP (que les différentes routes soient donc propagées entre les routeurs) et également qu’une route par défaut (vers l’extérieur du réseau), définie sur R2 soit propagée à R1 et R2 ce qui évitera de devoir leur définir une route par défaut statique.

Pour la suite de l’article, je pars du principe que les interfaces sont bien configurées (encapsulation, clock rate, adresse IP …) afin de me concentrer sur la configuration minimale de RIP.

RIP en quelques mots

RIP (Routing Information Protocol) est un protocole de routage. Il permet à chaque routeur de communiquer aux autres routeurs la distance qui les sépare du réseau, c’est-à-dire dans ce cas-ci le nombre de sauts.

RIP est limité par quelques caractéristiques. Par exemple il ne supporte que 15 sauts au maximum, au delà de quoi les paquets sont détruits. De plus il ne tient compte que de la distance d’un point à un autre pour définir « sa » meilleure route, il ne prend pas en compte la bande passante ou tout autre paramètre qui peut influer sur la vitesse de transfert par exemple.

RIP existe en version 1 et en version 2. La différence principale est que RIPv2 n’accepte pas les adresses réseau de type « classless » (dont le masque de sous-réseau ne correspond pas à une classe A, B ou C). Deplus RIPv1 broadcast ses routes, tandis que RIPv2 utilise du multicast. (Il consomme donc moins de ressources réseau).

On utilisera donc RIPv2.

Configuration de R3

On va ici définir la route par défaut vers l’extérieur donc vers 0.0.0.0 0.0.0.0, ensuite on va activer RIP, le passer en version 2 et définir les adresses de réseaux qu’il doit gérer. Pour finir on va lui dire de propager ses routes statiques (donc la route par défaut).

Un petit détail à savoir, lorsqu’on active un protocole de routage, la configuration de’une « default-gateway » n’est pas prise en compte. On doit définir une route statique vers 0.0.0.0 0.0.0.0.

R3(config)# ip route 0.0.0.0 0.0.0.0 Serial 1/2
R3(config)#router rip
R3(config-router)# version 2
R3(config-router)# network 10.0.0.0
R3(config-router)# redistribute static
R3(config-router)# exit

Configuration de R1 et R2

Pour R1 et R2 le travail est exactement le même sauf qu’on ne lui demande pas de propager les routes statiques et qu’on ne doit pas définir de route par défaut.

R1(config)#router rip
R1(config-router)# version 2
R1(config-router)# network 10.0.0.0
R1(config-router)# exit
R2(config)#router rip
R2(config-router)# version 2
R2(config-router)# network 10.0.0.0
R2(config-router)# exit

Voilà qui est fait, il reste maintenant à observer le résultat. Pour celà il suffit d’aller par exemple sur R2:

R2# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
 D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
 N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
 E1 - OSPF external type 1, E2 - OSPF external type 2
 i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
 ia - IS-IS inter area, * - candidate default, U - per-user static route
 o - ODR, P - periodic downloaded static route

Gateway of last resort is 10.0.3.5 to network 0.0.0.0

 10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.0.2.0/24 is directly connected, FastEthernet0/1
R       10.0.3.0/30 [120/1] via 10.0.3.5, 00:00:14, Serial1/0
R       10.0.1.0/24 [120/2] via 10.0.3.5, 00:00:14, Serial1/0
C       10.0.3.4/30 is directly connected, Serial1/0
R       10.0.4.0/24 [120/1] via 10.0.3.5, 00:00:14, Serial1/0
R*   0.0.0.0/0 [120/1] via 10.0.3.5, 00:00:14, Serial1/0

La lettre qui précède les lignes de routage indiquent d’où elles proviennent:

  • C : Réseau directement connecté au routeur
  • S : Route statique
  • R : Route ajoutée par RIP
  • * : Route par défaut, ici précédée de R puisqu’elle a été propagée par RIP
VN:F [1.9.22_1171]
Rating: 9.0/10 (13 votes cast)
Configuration de base de RIP, 9.0 out of 10 based on 13 ratings
Posted in Cisco, La pratique, Routing
Tags: , , , , ,
5 commentaires sur “Configuration de base de RIP
  1. Laurent dit :

    Bonjour, très bon article ! J’ai vu une petite erreur de frappe « La différence principale est que RIPv2 n’accepte pas les adresses réseau de type « classless » », il faut comprendre  » … est que RIPv1 … » . Cdlt, Laurent.

  2. cyberjackweb dit :

    bonjour, j’ai un soucis de configuration RIP avec mon router Cisco 2620XM ver 12.2. au bout de quelques minutes les routes ne sont plus et disparaissent « Show ip route »

    • Difficile de dire ce qui se passe avec peu d’informations. Si vous pouvez me décrire votre topologie et me dire comment vous avez configuré RIP, je pourrais surement ovus en dire plus.

  3. cyberjackweb dit :

    Bonsoir merci de votre retour, je vais vous faire des captures d’écran et vous communiquez ma config

  4. cyberjackweb dit :

    voici la config

    BIENVENUE SUR LE RESEAU CJO-SYSTEM.

    User Access Verification

    Password:
    R1A-CISCO>enable
    Password:
    R1A-CISCO#show conf
    Using 3301 out of 29688 bytes
    !
    version 12.1
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname R1A-CISCO
    !
    no logging console
    enable secret 5 $1$RKzE$OXkeUw9UNsyBV8zk3Tl0w.
    enable password 7 140D4A5D09172C3B286C
    !
    !
    !
    !
    !
    ip subnet-zero
    no ip domain-lookup
    no ip dhcp relay information check
    !
    !
    !
    !
    !
    !
    interface Loopback0
    ip address 10.10.10.10 255.255.255.255
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.93
    description CONNECTED TO VLAN 93 DEDICATED WIFI
    encapsulation dot1Q 93
    ip address 10.93.xxx.254 255.255.255.0
    ip helper-address 10.227.xxx.230
    ip nat inside
    !
    interface FastEthernet0/0.192
    description CONNECTED TO VLAN 192 DEDICATED DMZ PUBLIC BOX
    encapsulation dot1Q 192
    ip address 192.168.xxx.xxx 255.255.255.0 secondary
    ip address 192.168.xxx.xxx 255.255.255.0 secondary
    ip address 192.168.xxx.xxx 255.255.255.0
    ip nat outside
    !
    interface FastEthernet0/0.810
    description CONNECTED TO VLAN 810 DEDICATED ADMIN SERVER
    encapsulation dot1Q 810
    ip address 10.227.xxx.254 255.255.255.0
    ip nat inside
    !
    interface BRI0/0
    no ip address
    shutdown
    !
    router rip
    redistribute connected
    network 10.0.0.0
    !
    ip nat inside source list 1 interface FastEthernet0/0.192 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.xxx.xxx
    ip http server
    !
    access-list 1 permit 10.227.xxx.0 0.0.0.255
    access-list 1 permit 10.93.xxx.0 0.0.0.255
    banner motd ^C
    BIENVENUE SUR LE RESEAU CJO-SYSTEM.^C
    !
    line con 0
    line aux 0
    line vty 0 4
    password 7 083B14180C0A03071E4F
    login
    transport input telnet
    !
    end

Laisser un commentaire

Visit Us On FacebookVisit Us On GooglePlusVisit Us On TwitterVisit Us On LinkedinVisit Us On YoutubeCheck Our Feed

Archives

Connexion à WordPress protégée par Clef
%d blogueurs aiment cette page :