Configuration simple de VLANS sur un switch

Un VLAN est en quelque sorte un sous-réseau virtuel, généralement associé à une adresse sous-réseau propre. Cela implique donc que les vlans ne peuvent pas communiquer entre eux à moins que l’on utilise un routeur…

Que faut-il configurer ?

  1. Avoir une liaison fonctionelle entre le switch et le routeur.
  2. Définir la liason entre le switch et le routeur comme un « trunk »
  3. Créer les vlans sur le switch
  4. Attribuer les interfaces désirées dans les différents vlans (uniquement utiles pour l’administration du switch).
  5. Pour chaque VLAN sur le switch, créer une sous interface (sur celle utilisée par le trunk).

Remarque: Les switches d’ancienne génération n’acceptent pas plus d’une interface de type « vlan ».

Exemple concret
On dispose d’un Switch (24 ports FastEthernet, 2 ports Gigabits) et d’un routeur ( 1 port Gigabit, 1 port série). On souhaite diviser le switch en 4 VLANS diposant chacun de 6 Interfaces Fa.

  1. VLAN1:   192.168.1.0 / 255.255.255.0  Fa0/1-Fa0/6
  2. VLAN2:   192.168.2.0 / 255.255.255.0  Fa0/7-Fa0/12
  3. VLAN3:   192.168.3.0 / 255.255.255.0  Fa0/13-Fa0/18
  4. VLAN4:   192.168.4.0 / 255.255.255.0  Fa0/19-Fa0/24

On commence donc par se connecter au CLI du Switch et on crée les différents vlans. On leur attribue également une adresse IP de manière à pouvoir les gérer à distance par la suite. (Rmq: les commandes utilisées ici sont celles disponibles sur un switch Cisco 2960).

On entre en mode de configuration:

Switch>en
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.

On configure l’ip du VLAN1 (qui existe par défaut) en 192.168.1.254 / 255.255.255.0

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.254 255.255.255.0
Switch(config-if)#no shut
%LINK-5-CHANGED: Interface Vlan1, changed state to up
Switch(config-if)#
Switch(config-if)#exit

On crée et on configure les VLAN2, 3 et 4 avec respectivement les adresses 192.168.2.254, 192.168.3.254 et 192.168.4.254 et un masque 255.255.255.0.

Switch(config)#vlan 2
Switch(config-vlan)#name VLAN2
Switch(config-vlan)#exit
Switch(config)#interface vlan 2
%LINK-5-CHANGED: Interface Vlan2, changed state to up
Switch(config-if)#ip address 192.168.2.254 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#vlan 3
Switch(config-vlan)#name VLAN3
Switch(config-vlan)#exit
Switch(config)#interface vlan 3
%LINK-5-CHANGED: Interface Vlan3, changed state to up
Switch(config-if)#ip address 192.168.3.254 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit
Switch(config)#vlan 4
Switch(config-vlan)#name VLAN4
Switch(config-vlan)#exit
Switch(config)#interface vlan 4
%LINK-5-CHANGED: Interface Vlan4, changed state to up
Switch(config-if)#ip address 192.168.4.254 255.255.255.0
Switch(config-if)#no shut
Switch(config-if)#exit

On place maintenant les interfaces dans les vlans.

Switch(config)#interface range fastEthernet 0/7-12
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 2
Switch(config-if-range)#no shut
Switch(config-if-range)#exit
Switch(config)#interface range fastEthernet 0/13-18
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 3
Switch(config-if-range)#no shut
Switch(config-if-range)#exit
Switch(config)#interface range fastEthernet 0/19-24
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 4
Switch(config-if-range)#no shut
Switch(config-if-range)#exit

On vérifie que tout est bien en place. (on utilise ici « do show vlan » puisque la commande « show vlan » n’est pas disponible en mode config).

Switch(config)#do show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Gig1/1, Gig1/2
2    VLAN2                            active    Fa0/7, Fa0/8, Fa0/9, Fa0/10
                                                Fa0/11, Fa0/12
3    VLAN3                            active    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18
4    VLAN4                            active    Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                                Fa0/23, Fa0/24

On passe maintenant à la configuration de la liaison avec le routeur qui doit être un trunk. On utilise ici l’interface Gigabit 1/1.

Switch(config-if)#switchport mode trunk
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/1, changed state to up
Switch(config-if)#exit

On va s’occuper maintenant de la configuration du routeur, sur lequel on créera des sous-interfaces pour chaque VLAN supplémentaires créés. Et de les configurer (IP, …). A noter qu’il faut configurer l’encapsulation de la sous interface pour pouvoir lui attribuer une adresse IP.

Router>en
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int gigabitEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shut

Ceci correspond à l’adresse principale de l’interface, et également au VLAN1.

Créons maintenant la sous-interface pour le VLAN2.

Router(config)#int gigabitEthernet 0/0.2
%LINK-5-CHANGED: Interface GigabitEthernet0/0.2, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.2, changed state to up
Router(config-subif)#encapsulation dot1Q 2
Router(config-subif)#ip address 192.168.2.1 255.255.255.0
Router(config-subif)#no shut
Router(config-subif)#exit

On fait de même pour les interfaces relatives aux VLAN 3 et 4.

Router(config)#interface gigabitEthernet 0/0.3
%LINK-5-CHANGED: Interface GigabitEthernet0/0.3, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.3, changed state to up
Router(config-subif)#encapsulation dot1Q 3
Router(config-subif)#ip address 192.168.3.1 255.255.255.0
Router(config-subif)#no shut
Router(config-subif)#exit
Router(config)#interface gigabitEthernet 0/0.4
%LINK-5-CHANGED: Interface GigabitEthernet0/0.4, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0.4, changed state to up
Router(config-subif)#encapsulation dot1Q 4
Router(config-subif)#ip address 192.168.4.1 255.255.255.0
Router(config-subif)#no shut
Router(config-subif)#exit

Dans la commande « encapsulation dot1Q 4 », le chiffre en fin de ligne correspond au n° du VLAN

Si tout c’est bien déroulé, la configuration des vlans est maintenant terminée. Il ne suffit plus que de connecter les machines sur les différents VLANS et les configurer avec des adresses IP du même range que le VLAN où elles se trouvent.

Remarque: Lorsque les VLANS doivent être propagés sur plusieurs switch, la configuration est un peu plus complexe, puisqu’il faudra alors configurer l’utilisation du protocol VTP… mais ce sera pour un autre article 😉

VN:F [1.9.22_1171]
Rating: 8.4/10 (39 votes cast)
Configuration simple de VLANS sur un switch, 8.4 out of 10 based on 39 ratings
Posted in CCENT - ICND1, Certifications, Cisco, La pratique, Switching
Tags: , , , , ,
28 commentaires sur “Configuration simple de VLANS sur un switch
  1. Meikai(Zaurak) dit :

    je sens que ça va pas mal me servir pour mes PTI (épreuves pratiques pour mon examen) en juin. Evite de supprimer ton blog d’ici là au cas ou !

  2. Dans le pire des cas il sera déplacé 😉

  3. mims dit :

    merciiiiiii ça ma pas mal aidé j’ai une epreuve ojourdèhuib éspérons kça va bien se passer 🙂

  4. Meikai dit :

    L’interêt c’est quoi ? C’est donc pas d’empêcher certaines machines de communiquer ensemble.. Ca sert à éviter que des émissions de Broadcast, enfin de diminuer le domaine de diffusion ?

  5. Les intérêts sont multiples… en effet ça permet de réduire les domaines de broadcast en les scindant en plusieurs morceaux… mais ça permet aussi d’isoler une série de machines par exemple on peut imaginer avoir un VLAN pour les workstations en filaire et un autre pour les workstations en Wifi.
    Les VLANs sont aussi la base de techniques permettant d’interconnecter des sites distants en passant par un « provider » qui met à disposition un réseau commuté au niveau de la couche liaison de données etc.

    Mais en effet la première utilité c’est créer une division logique au sein d’un réseau physique. (sécurité etc). Vu que deux réseaux distincts ne peuvent communiquer qu’en passant par un routeur ça permet d’y appliquer des règles de filtrage etc.

  6. TBGC dit :

    MERCI,, CE BLOG ET CET ARTICLE M’AIDE BEAUCOUP DANS MON APPRENTISSAGE DU CISCO

  7. max dit :

    je crois que j’ai un peu de lumière pour mon début d’apprentissage en Cisco

  8. Cury dit :

    Merci bro’

  9. FABIOD dit :

    merci infiNIment bro. tu pourrais aller un peu plus loin ?

  10. kone check dit :

    merci pour ce point qui m’aidera a rediger mon rapport de stage

  11. DANIEL dit :

    merci merciiii

  12. Isaac dit :

    Bonjour… Merci pour ce brillant Tito. Ça ma beaucoup aider. Dites comment est ce que je peux avoir la suite pour le vtp ???

  13. Josler dit :

    Ok, Je trouve quelques faits importants qui vont m’aider

  14. bizous nours dit :

    Bonjour,
    Juste pour signaler qu’il est absolument inutile de configurer et d’attribuer une IP à chaque VLAN créer sur un switch, sauf dans le cas d’un switch niveau 3.
    Or ici le niveau 3 sera assuré par un routeur, qui lui doit avoir une IP associé pour chaque VLAN.
    Bien cordialement

    • C’est tout à fait exact, c’est d’ailleurs la raison pour laquelle j’avais indiqué « Attribuer les interfaces désirées dans les différents vlans (uniquement utiles pour l’administration du switch). » 😉 … Ca permet en outre dans une certaine mesure de tester le routage inter-vlan sans avoir besoin de connecter de machine sur le switch.

  15. Lucien dit :

    Bonjour Steve,

    Je ne comprends pas cette réponse:

    C’est tout à fait exact, c’est d’ailleurs la raison pour laquelle j’avais indiqué « Attribuer les interfaces désirées dans les différents vlans (uniquement utiles pour l’administration du switch). » … Ca permet en outre dans une certaine mesure de tester le routage inter-vlan sans avoir besoin de connecter de machine sur le switch

    J’ai bien compris qu’il faut attribuer une IP à un VLAN pour administrer le switch. Dans nos cas avec 4Vlans je ne comprends pas l’interet d’avoir 4 @IPs pour configurer le switch une seul suffit non?

    comment tester le routage inter-vlan sans besoin de connecter de machine sur le switch?

    Merci par avance,

    • En effet une seule adresse IP permet d’accéder au management du switch, toutefois cela permet de simuler l’existence de plusieurs réseaux et donc de tester les communications avec ceux-ci.
      Pour ce qui concerne le routage inter-vlan, dans une certaine mesure, cela dépend des plateformes, il est possible tester la communication (ping par exemple) depuis le switch vers lui-même en passant par un routeur puisqu’on passe d’un vlan à l’autre.

  16. Lucien dit :

    super Steve j’ai bien compris.

  17. Lucien dit :

    Bonjour Steve,

    Je viens de faire des tests de ping pour simuler l’existence de plusieurs reseaux via l’utilisation des interface VLAN cela fonctionne tres bien mais j’ai cependant une question.

    Si mon switchA à 2 vlan: VLAN 10 et VLAN30 relié en mode trunk sur un routeur configuré en dot1q
    SI mon switchB à 2 vlan VLAN 10 et VLAN 40 relie en mode trunk sur le switchA

    Pourquoi je n’arrive pas à pingé int VLAN 40 à qui bien sur jai configuré encapsulation dot1q sur le routeur.
    La communication fonctionne des lors que je cree le VLAN 40 sur le switchA.

    D’ou vient ma question que se passe t’il lors de l’envoi d’une trame tagé vlan40 du switchB vers le switchA (quand il ne connait pas ce VLAN)

    Merci par avance,

    Lucien

    • Une trame taguée pour le VLAN 40 arrivant au Switch A sera détruite. Pour que la trame puisse arriver jusqu’au routeur il faut que le vlan soit continu et donc qu’il existe sur le(s) switch(es) intermédiaires et qu’il soit autorisé sur les trunks.

  18. Barcelona1994 dit :

    merci pour le comprehension sur le vlan sur le switch

  19. NSII dit :

    Nous ne fermerons pas cette page sans présenter nos sincères remerciements pour cet éclaircissement sur la notion des VLAN émis à notre égard.

  20. mourad dit :

    merci pour votre aide

  21. cheikh dit :

    Bonjour

    Je voudrais savoir à quoi ca sert de mettre un configuration IP sur les interfaces des VLAN alors seules les IP des sous interfaces devraient permettre à cette topologie de fonctionner ?

    • Dans le cas présent, cela permet de communiquer avec le switch… par exemple pour l’accès via telnet ou SSH.

      • cheikh dit :

        Bonjour Merci pour ta réponse.
        Oui pour le VLAN par défaut je comprend qu’on puis lui attribuer des parametres IP pour le management.
        Je parle plutot de la config IP des autres VLANs

Laisser un commentaire

Visit Us On FacebookVisit Us On GooglePlusVisit Us On TwitterVisit Us On LinkedinVisit Us On YoutubeCheck Our Feed

Archives

Connexion à WordPress protégée par Clef
%d blogueurs aiment cette page :